Hack hack hack...

An open journal-- some of it written for you, but most of it is for me.

Diaspora- Day 2

Postgresql Gem is killing me. It’s listed in the Gemfile. It’s listed in the Gemlock file. I’ve tried to…

ok so after 2 hours of running around google I tried commenting out the mysql and sqlite gems:

1
2
3
4
5
6
7
# database

gem "activerecord-import", "~> 0.2.9"
gem 'foreigner', '~> 1.1.0'
#gem 'mysql2', '0.3.11' if ENV['DB'].nil? || ENV['DB'] == 'all' || ENV['DB'] == 'mysql'
gem 'pg' #if ENV['DB'] == 'all' || ENV['DB'] == 'postgres'
#gem 'sqlite3' if ENV['DB'] == 'all' || ENV['DB'] == 'sqlite'

bingo.

I finally got this running by downloading mysql and setting the db to mysql… victory.

Comments